
Playing Star Wars Epic Duels Online: A Tutorial 
 

So, you want to play Star Wars Epic Duels online?  Great!  Getting everything setup is 

fairly easy and playing online can be even more fun than playing in real life.  What follows 

is a step-by-step guide to get you from here to playing Epic Duels Online! 
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Introduction: 

To play SWED online you will need to download several different items from several 

different places.  This tutorial will show you where to download the necessary files and 

how to start a game.  It will also teach you how to use the VASSAL program (the engine 

that SWED is played on) and the SWED module (the game that VASSAL will load), 

including the installation of extensions. 

 

NOTE FOR MAC USERS: If you do not have a two-button mouse, when this guide 

instructs you to right-click, hold the Control key down when you click instead. 

 

1. Downloads 

The first thing you will need to do is download the VASSAL engine.  Go to 

www.vassalengine.org and click on the “downloads” link right on the main page.  You can 

also click the Downloads link in the upper left hand corner of the main page.  Click the 

install link for your operating system to install the engine. 

 

NOTE: Vassal 3.1.19 requires Java Runtime Environment (JRE) 5 or later. See the OS-

specific notes below for how to get an appropriate JRE for your system. 

 

The second thing you will need to download is the SWED module, which is the game that 

VASSAL will load when you try to play.  This module is also located on the VASSAL 

website.  Click on the “modules” link in the upper left hand corner of the main page and 

then scroll down the list of modules until you find “Star Wars: Epic Duels.”  Click on the 

link, and then click to download the lated version of the module (v3.2 as of this writing).  

Download the module and save it to the same folder that you saved the VASSAL engine.  

Remember where you save the module, and do not try to open the file by itself. 

 

2. Running VASSAL 

The VASSAL website has specific documentation about how to run the Engine, so please 

refer to their documentation for running their program. 

 



When you start VASSAL for the first time, click File->Open Module.  A browsing 

window will appear, and you will need to locate the SWED3-2.mod module you saved and 

select it.  Once you’ve selected it, click “Open.”  The module will now appear in the main 

VASSAL window program every time you start VASSAL. 

 

3. Starting a Game 

After you’ve located the module for VASSAL, from here on out, when you start VASSAL, 

just double-click the module from the main VASSAL window to start a game.  Doing so 

will open the start-up wizard for Epic Duels.  Just follow the instructions on screen to get 

things setup, and remember to “join side” as a player number (joining as an observer will 

limit what you can do).   

 

Once the map is loaded it’s time to select a character deck.  Click the “DECKS” button.  A 

window will appear with all 12 decks, including a random character deck (be sure to 

shuffle it by right-clicking before drawing a character).  NOTE: The random character 

deck is all the way to the right of the twelve character decks. You may need to scroll the 

window to see it. 

 

Once you’ve chosen your character, right click the appropriate deck and select the “Send to 

Game Table” function.  Your deck will appear in the “Player 1” slot on the game table 

map.  From there you will need to right click the deck again to “send to Player 2” (or 

farther around the table depending on how many players you have).  You MUST send your 

deck out of the Player 1 deck slot before another deck from the ED decks window can be 

sent, otherwise the two decks will be combined together and both will be unusable.  If you 

make a mistake simply click the “undo” button which is the farthest button to the left with 

the half circle arrow, under “File.” 

 

Now that you’ve got your deck, if you haven’t clicked the Figures button yet, do so now.  

The figures window, with a list of figures, will appear to the left.  Select the main character 

that matches the deck you picked and its picture will appear to the left.  Simply click the 

picture and drag/drop it to the map in order to use the figure.  The main characters are 

sorted alphabetically, and their corresponding minor character(s) will be directly 

underneath each main character, separated by dashes.  The “extension” tab will be 

explained later.  After you’ve dragged your figures to the board, you’re ready to duel! 

 

4. Playing a Game Online 

Now that you know how to run VASSAL and start a game, it’s time to learn how to 

connect to the VASSAL server and play a game online!  Unfortunately there is no 

“artificial intelligence” (AI), so there isn’t a “single player” mode.  AI is beyond the scope 

of VASSAL, and you will have to connect online and play a game with other people.  

  

If you didn’t select “Find a game online” in the startup wizard, then beneath the Help menu 

you’ll see a button with two arrows labeled CONNECT; pushing this will open the 

connection window.  This window will appear to the right, and you will need to click the 

double arrow button in this window to connect to the server.  Once you are connected you 

will see yourself in both the “Active games” and “Current games” windows, and you 

should be sitting in the “main room.”  If other people are online you will see them in 



various rooms in the “Active Games” window.  If no one else but you is in the Active 

Games window, then no one else is online.  To play online you need to be in any room 

except for the “main room.”  So either join a room by doubling clicking it, or create a new 

one by entering a name into the “New Game” box. 

 

You will now see yourself in your newly created room in both the Active Games and 

Current Games windows.  In order to play with another person they need to be in the same 

room as you.  Right-clicking the other person in the Current Games window will give you 

a menu of options.  Once you or your opponent has loaded a map, it’s time for you to 

synchronize to each other.  Whoever didn’t load the map needs to select synchronize and 

‘synch’ to the other person.  The person who synchs will be prompted to choose a side, and 

then the map will load for that person.  Whatever actions you take will now be visible by 

every other person that is synchronized to the same game table, and all actions will be 

reported to the chat window. 

 

Once you’ve synched and setup the board with characters and decks, you’re ready to play!  

Playing Epic Duels in VASSAL is essentially the same as playing in real life.  Click the 

die button to roll the die, then click and drag the figures around the board to move.  The 1-

6 buttons will open a “player hand” window that you may use to store cards. To draw a 

card simply click and drag a card from the deck to either the table or your player hand 

window (Note: there is very limited space on the table, so the use of hand windows is 

recommended).  It is important to know that ALL CARDS YOU DRAW WILL ALWAYS 

APPEAR TO YOU FACE-UP, BUT WILL APPEAR TO YOUR OPPONENT FACE-

DOWN.  In order to make one of your cards visible to your opponent, you should right-

click the card, and select “flip card.”  The card will appear the same to you, but it will be 

turned face-up to your opponent.  Select “flip card” again to turn it back face-down to your 

opponent.  To discard a card simply put it in the discard pile beneath your deck.  It is 

helpful to right-click your discard pile and select the “face-up” option. 

 

From here playing Epic Duels Online is the same as playing Epic Duels in real life.  Roll 

the die, move your figures, and play and draw cards.  You can chat with your opponents in 

the chat window or hold a private conversation by right-clicking their name in the Current 

Games window.  

 

Right-clicking a figure brings up a contextual menu with several commands that are 

important to playing the game. To change a character’s hit points as it takes damage, right-

click the figure and choose Hit Points; enter the adjusted total. There is also a “Turn 

Sideways” command in the case of a character that is the target of Yoda’s Force Lift card. 

Use the “Stand Back Up” command to return a character to normal status. If you wish to 

label your characters (such as calling your clone troopers “Trooper 1” and “Trooper 2” for 

simplicity in declaring attacks), right-click the character to label and choose Change Label. 

Then simply type whatever label you would like. Finally, when a character is destroyed, 

right-click it and choose “Delete Character” from the menu. 

 

To start a new game, just select “New Game” from the File menu.  You can use the MAPS 

button to randomly help you select a new map (but you’ll have to manually select it 

yourself). 



5. Extensions 

The Epic Duels module only contains the decks, figures and maps that came with the 

original Hasbro game.  However, there are several custom decks and maps in existence, 

and in order to use them you must load them as “extensions” to the original module. 

 

There are two ways to load extensions in VASSAL.  Once you’ve downloaded or created 

an extension to use, VASSAL needs to be able to find it.  The first and most easy way, is to 

right-click the module from the main VASSAL start window, and select “add extensions”.  

A browsing window will pop up, so find your extension, and click open.  You’ll see the 

extension now listed underneath the module in the main window.  The second, and slightly 

more involved way, is to manually create a new folder that VASSAL will use to load the 

extensions.  You will need to create this new folder in the same location that the module is 

located.  The name of the folder must match the name of the module exactly, but with the 

suffix “_ext” at the end. For example, for the 3.2 version of the module (current as of this 

writing) you need to name this folder “SWED3-2_ext”.  It is important that the name of the 

extension folder matches the name of the module exactly with “_ext” added to the end; if 

this folder is not in the correct location and/or is not named correctly, the extensions will 

not load.  Then, simply place extensions into this folder and VASSAL will load them when 

you restart the program. 

 

If you’ve done this correctly, each extension will load when you restart the module.  A 

message in the chat window should indicate which extensions loaded successfully when 

you start up the game.   

 

The extensions you load will affect the module in individual ways depending on what the 

extension is.  Some extensions add new buttons, and some extensions add more options to 

existing windows.  For example, most deck extensions will appear in the “EXT” window, 

and their corresponding figures will appear in the “Extensions” tab of the Figures window.  

Most map extensions will simply be added to the map drop down menu. 

 

6. Logfiles and Saving Games 

It is possible to save a game and finish playing it later.  It is also possible to record a logfile 

of any game and then watch it after you are finished. 

 

To save a game, simply go to File->Save Game.  Select a location for the “Save Game” 

file, name it, and then click save.  When you want to come back to the saved game, after 

loading VASSAL, select “Load game” instead of “New game”, and your saved game will 

load.  Then after it loads, synch up with your partner pick up where you left off. 

 

To create a logfile of a game, simply go to File and select “Begin Logfile” before you start 

a game.  You will be prompted to select a location and a name for the logfile.  Selecting 

Save will begin the logfile.  When you are finished with the game and want to end the 

logfile, go to File and select “end logfile.”  A message will appear in the chat window 

“logfile written” if you’ve done this correctly. If you quit VASSAL before ending the 

logfile, the logfile will be corrupt and you will lose the record of your game.  



NOTE TO EDOL MEMBERS: Any League game that has no logfile is null and void, so 

make SURE that both players are saving a log in case anything happens or you will be 

forced to replay the match. 

 

To watch a logfile of a past game, when you startup VASSAL select “load game” instead 

of “new game.”  Locate the logfile you saved, select it and click Open, and this will load 

the logfile.  Directly under Help will be a button marked with a right-pointing triangle.  

Clicking this button will advance the game one step at a time through the logfile.  Each 

action that was logged, all the text that was typed into the chat window and the physical 

movements on the board will appear.  Simply click this button repeatedly to view all the 

logged actions of the game in the order they happened. 

 

7. Voice Chatting 

While VASSAL doesn’t have any voice chatting support built-in, there are a couple of 

options for voice chatting during games so players don’t have to rely solely on the text-

based chat window to communicate.  Keep in mind that a microphone and speakers 

(preferably headphones) are required to use voice chatting software.  Some webcams and 

laptops have microphones built-in, but you can also find dedicated headsets with 

microphones that work well. What follows are a few 3
rd

 party options for voice chatting. 

 

Option 1: Teamspeak 

First, download TeamSpeak at: “http://www.teamspeak.com/?page=downloads”.  Then 

install and run TeamSpeak.  Select Connections, then Connect from the drop-down menu. 

Enter "74.98.221.50:9988" into the Address box and type your name into the Nickname 

box.  Leave the Password box empty. Click Connect. To play a casual game, you can 

create a temporary channel and invite friends to join you.   

 

NOTE TO EDOL MEMBERS: Tournaments that require TeamSpeak will have a 

dedicated lobby setup.  Users can join the Epic Duels Lobby by entering the appropriate 

password. The password for the tournament lobby will be given out as needed. 

 

Option 2: Yahoo Voice Chat 
Many users that play Epic Duels online, are also members in various yahoo groups, and 

therefore have a yahoo username already established for yahoo messenger.  Built right into 

yahoo messenger is the voice chat option.  After installing and running the latest yahoo 

messenger, the voice chat function is labeled as “calling” a contact.  With the chat window 

open, click “call” and select “call computer”.   
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